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Abstract :     

Molecular docking is the computer-aided prediction of the bound geometry of two or more molecules. 

Molecules may be docked manually with the aid of computer graphics or automatically by using computer 

algorithms. This tutorial aimed to design a step by step protocol to get the basic insight into the molecular 

docking calculations employing very simple and easy to follow procedure. In this article the   N-terminal 

SH2 domain of Grb10 docked against with Cyclobutaneoctol as a ligand Using the AUTODOCK TOOLS 

1.5.7. 

 

IndexTerms -  Molecular docking;Auto dock; Human insulin receptor; Protein-ligand interactions. 

 

I. INTRODUCTION 

 

INTRODUCTION 

  

Ligand-receptor molecular docking is a significant computational method to study intermolecular 

interactions and predict the structure of complex based on the principle of shape complementarity and 

property complementarity between ligand and receptor. Molecular docking is mandatory for the discovery 

of new drugs [1] because a lot of emerging diseases demand prompt treatments, such as COVID-19. 

Diabetes mellitus termed as metabolic disorder is a collection of interlinked diseases and mainly body’s 

inability to manage glucose level which leads to cardiovascular diseases, renal failure, neurological 

disorders, and many others. The drugs contemporarily used for diabetes have many inevitable side effects, 

and many of them have become less responsive to this multifactorial disorder. 

The World Health Organization (WHO) evaluate that about 200 million people all over the world are 

suffering from diabates and the figure is possible to be doubled by 2030. 

One of the cause of type 2 diabetes mellitus is the improper regulation of insulin signal transduction 

pathyway.phosphatidylinositol-3-kinase(PI-3K) is one of the important components in the regulation of the 

insulin signaling pathway. It maintains the insulin sensitivity in the liver. PI-3K is composed of a regulatory 

subunit (P85) and a catalytic subunit (P110).P85 regulates the activation of PI-3K enzyme[1].In the Pl-3K 

heterodimer (P85-p110),P85 is responsible for the PI-3K activity by binding to the binding site on the 

insulin receptor Substrates (IRS). The increase in the P85 (isomer of P85) results in the competition between 

the later and the P85-P110 complex to the IRS binding site , reducing the PI-3K activity and leading to 

insulin resistance[2]. Therefore inhibit the increase of the P85 leads to  proper regulation of insulin 

transduction pathway. Molecular docking is such a structure based drug design method stimulates the 
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molecular interaction and predicts the binding mode and affinity between receptors and ligands. In recent 

years, this technology has been widely used in drug design research field [3]. In this article the PI-3 Kinase 

p85 N-terminal SH2 domain docked with Cyclobutaneoctol as a ligand Using the AUTODOCK TOOLS 

1.5.7. 

 

 

 RESEARCH METHODOLOGY 

 

 This methodology described step by step protocol to perform molecular docking study of human insulin 

receptor with Cyclobutaneoctol from basic required Tools up-to the visualization steps of protein-drug  

interactions. 

 AutoDock 

AutoDock is a suite of automated docking tools. It is designed to predict how small molecules, such as 

substrates or drug candidates, bind to a receptor of known 3D structure. Over the years, it has been modified 

and improved to add new functionalities, and multiple engines have been developed.Current distributions of 

AutoDock consist of two generations of software: AutoDock 4 and AutoDock Vina. More recently, we 

developed AutoDock-GPU, an accelerated version of AutoDock4 that is hundreds of times faster than the 

original single-CPU docking code. 

AutoDock 4 actually consists of two main programs: autodock performs the docking of the ligand to a set of 

grids describing the target protein; autogrid pre-calculates these grids. 

 Molegro Molecular Viewer 

Molegro Molecular Viewer is a free software application for visualization of molecules and Molegro Virtual 

Docker results. The latest version of MMV is 7. 0 (released March 26th, 2019). 

 

Downloading and installation of basic tools: 

To download AutoDock, go to 

https://ccsb.scripps.edu/mgltools/downloads/  

To download Molegro Molecular Viewer,  go to  

http://molexus.io/molegro-molecular-viewer/  

Ligand preparation: 

Cyclobutaneoctol(PDB ID : ) obtained from PUBCHEM(https://pubchem.ncbi.nlm.nih.gov/) Download 

ligand   

STEPS INVOLED IN MOLECULAR DOCKING: 

 STEP 1: Target/Receptor selection and preparation 

 STEP 2; Ligand selection and preparation 

 STEP 3: Docking 

 STEP 4: Evaluating docking results 

STEP 1: TARGET/RECEPTOR SELECTION AND PREPARATION: 

The 3D structure of target/receptor are obtained from protein data bank[http:// www.rscb.org]. The first step 

is to prepare the receptor coordinate files to include the information needed by AutoGrid and AutoDock. 

These coordinate files are created in an AutoDock-specific coordinate file format, termed PDBQT, which 

includes: 

 Polar hydrogen atoms 

 Partial charges 

 Atom types 

 Information on the articulation of flexible molecules 

http://www.ijrti.org/
https://ccsb.scripps.edu/mgltools/downloads/
http://molexus.io/molegro-molecular-viewer/
https://pubchem.ncbi.nlm.nih.gov/
http://www.rscb.org/
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For a typical docking calculation, you will create a separate file of coordinates for the receptor. In dockings 

where selected amino acids in the receptor are treated as flexible, you will create a third file that includes the 

coordinates of the atoms in the flexible portions of the receptor. In a typical study, prepares coordinate files 

in several steps using AutoDock Tools. A detailed tutorial is available on the AutoDock WWW site to 

guide you through this process. The first two steps may be performed using the tools in the Edit menu of 

AutoDockTools or with other molecular modeling programs, 

 Add hydrogen atoms to the molecule. 

 Add partial charges. Then, read the molecule into AutoDockTools using the Ligand (for the ligand) 

or Grid (for the receptor) menus, and create the PDBQT file: 

 Delete non-polar hydrogens and merge their charges with the carbon atoms. 

 Assign atom types, defining hydrogen bond acceptors and donors and aromatic and aliphatic carbon 

atoms. 

 Choose a root atom that will act as the root for the torsion tree description of flexibility. 

 Define rotatable bonds and build the torsion trees. 

Creating PDBQT files of target/receptor: 

 File>ReadMolecule: opens a browser that allows reading of PDB coordinate files. 

 Edit>Delete: several options for deleting entire molecules, selected sets of atoms, or hydrogen 

atoms. 

 Edit>Hydrogens>Add: options for adding all hydrogens or polar hydrogens using Babel. 

 Edit>Charges: options for computing Gasteiger charges for arbitrary molecules using Babel. 

STEP 2: LIGAND SELECTION AND PREPRATION: 

The 3D structure of ligand can be obtained from database pubchem or can be sketched using tools like 

chemsketch. 

Creating PDBQT  files of ligand: 

Once ligand coordinates are created with hydrogen atoms and charges, they can be processed in the 

“Ligand” menu to create the ligand PDBQT file. 

 Ligand>Input>QuickSetup: uses defaults to create the PDBQT file. PDB files can be read from the 

PMV viewer or from a file, and written directly to a new PDBQT file. Please note that hydrogen 

atoms will not be added. 

 Ligand>Input>Open: reads coordinates from a file. 

 Ligand>Input>Choose: chooses a molecule already read into PMV. 

 Ligand>Input>OpenAsRigid: reads an existing PDBQT file and writes a new file with NO active 

torsions. 

 Ligand>TorsionTree>ChooseRoot: manual selection of the root atom. 

 Ligand>TorsionTree>DetectRoot: automatic detection of the root that provides the smallest 

largest subtree. 

http://www.ijrti.org/
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 Ligand>TorsionTree>ShowRootExpansion: for molecules with several atoms in the root, displays 

small spheres to show all atoms in the root, including atoms connected to each root atom by rigid 

bonds. 

STEP 3: DOCKING: 

Docking mainly involve two steps: 1.Running Autogrid  2.docking with Autodock . 

 RUNNING AUTOGRID: 

AutoDock requires pre-calculated grid maps, one for each atom type present in the ligand being docked. 

This helps to make the docking calculations fast. These maps are calculated by AutoGrid. A grid map 

consists of a three-dimensional lattice of regularly spaced points, surrounding (either entirely or partly) and 

centered on some region of interest of the macromolecule under study. This could be a protein, enzyme, 

antibody, DNA, RNA or even a polymer or ionic crystal. Typical grid point spacing varies from 0.2Å to 

1.0Å, and the default is 0.375Å (roughly a quarter of the length of a carbon-carbon single bond). Each point 

within the grid map stores the potential energy of a ‘probe’ atom or functional group that is due to all the 

atoms in the macromolecule. AutoGrid requires a grid parameter file to specify the files and parameters 

used in the calculation. The grid parameter file usually has the extension “gpf”. As described below, 

AutoDockTools may be used to create the grid parameter file. 

Creating grid parameter files in AutoDock Tools: 

• Grid>OpenGPF: gets parameters from an existing grid parameter file. 

• Grid>Macromolecule: has options for opening an existing PDBQT file or choosing a molecule that 

has been read using PMV. 

• Grid>SetMapTypes: tools to define the atom types for the grids that will be calculated. The option 

“Directly” allows the user to input the list of atom types directly and to open ligand or flexible 

residue PDBQT and use the atom types in these files. 

• Grid>SetMapTypes>SetUpCovalentMap:  specifies parameters for creation of a covalent map, 

which may be used in specialized applications to favor binding of a given ligand atom in a single 

position. 

• Grid>GridBox: launches interactive commands for setting the grid dimensions and cnter. 

IMPORTANT: when finished, use the “close saving current” option in the “File” menu on the Grid 

Options Panel. Options in the “Center” menu on the browser provide different methods to choose the 

center of the grid box. 

• Grid>OtherOptions: allows specification and editing of an existing parameter file. Grid>Output: 

writes a new grid parameter file. 

 DOCKING WITH AUTODOCK: 

AutoDock uses one of several conformational search algorithms to explore the conformational states of a 

flexible ligand, using the maps generated by AutoGrid to evaluate the ligand-protein interaction at each 

point in the docking simulation. AutoDock requires: 1) grid maps for each atom type in the ligand, 

calculated by AutoGrid, 2) a PDBQT file for the ligand, and 3) a docking parameter file that specifies the 

http://www.ijrti.org/
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files and parameters for the docking calculation. AutoDockTools may be used to generate the docking 

parameter file, as described below, 

Creating docking parameter files in AutoDockTools: 

• Docking>OpenDPF: gets parameters from an existing docking parameter file. 

• Docking>Macromolecule>SetRigidFilename: 

• Docking>Macromolecule>SetFlexibleResiduesFilename: these two commands specify the 

PDBQT file name that will be used for the rigid receptor, and if flexible receptor residues are used, 

specifies the PDBQT file name for the flexible portion of the receptor. 

• Docking>Ligand>Choose 

• Docking>Ligand>Open: These two commands allow the user to choose a ligand that is already 

read into ADT, or open an existing ligand PDBQT file. 

• Docking>Ligand>Ligand_Parameters: opens a panel for setting various ligand parameters, 

including the starting values for the translation, rotation, and torsion angles. 

• Docking>SearchParameters>GeneticAlgorithmParameters: 

• Docking>SearchParameters>LocalSearchParameters: these three commands open a panel for 

setting the parameters used by each of the search algorithms, such as temperature schedules in 

simulated annealing and mutation/crossover rates in genetic algorithms. 

• Docking>DockingParameters: opens a panel for setting the parameters used during the docking 

calculation, including options for the random number generator, options for the force field, step sizes 

taken when generating new conformations, and output options. 

• Docking>OtherOptions: specifies the name of an external atomic parameter file, if used. 

• Docking>Output>LamarckianGA: Docking>Output>GeneticAlgorithm. 

• Docking>Output>LocalSearch: These four commands write the docking parameter file using one 

of the four available search methods. 

• Docking>Edit: interactive editor for docking parameter files, which allows viewing of the latest 

docking parameter file written by AutoDockTools.  

 

STEP 4: EVALUATING THE RESULTS: The ligand is docked into the receotor and the 

interactions are checked. The scoring function generates score, depending on which the best ligand is 

selected. 
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IV. RESULTS AND DISCUSSION 

Ligand preparation: 

Cyclobutaneoctol(PDB ID : ) obtained from PUBCHEM(https://pubchem.ncbi.nlm.nih.gov/) Download 

ligand in SDF format. After downloading this ligand it will be viewed by Molegro molecular viewer (MMV 

software). Ligand was converted into SDF format to PDB format by using Molegro molecular viewer 

software.This PDB format ligand should be taken for the further docking process.The 3D structure of the 

ligands given in figure no:1.  

                

 

Fig no.1 ligand 

 

Protein preparation: 

   Crystal structure of  the SH2 domain of Grb10(PDB ID: INRV) obtained from RSCB PDB homepage 

(https://www.rcsb.org/). Download the protein in PDB format.After downloading of this protein it will 

viewed by Molegro molecular viewer software and remove cofactors,water,ligands and save this protein in 

PDB format. The saved protein will be given in the figure no 2. 

 

 

 

 

Fig no 2 Protein 

Docking analysis: 

http://www.ijrti.org/
https://pubchem.ncbi.nlm.nih.gov/
https://www.rcsb.org/
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Result of cyclobutaneoctol docked with crystal structure of the SH2 domain of Grb10: 

 

Docking computation of Cyclobutaneoctol towards the 3D structure of crystal structure of the SH2 domain 

of Grb10 (PDB ID : 1NRV) was performed by using the software Auto dock Tools 1.5.7. Crystal structure 

of the SH2 domain of Grb10 ( PDB ID:1NRV)domain was obtained from the RSCB PDB homepage.Crystal 

structure of SH2 domain of Grb10 was prepared by removing all the water molecules so that it’s active sites 

can be effectively binds to the ligand.The active sites were confined in a grid box to compute the binding 

ability of active sites with ligands.Prior to it,1NRV and Cyclobutaneoctol was optimized,genetic algorithm 

and Lamarckian algorithm was used in the auto dock Tools 1.5.7. The number of hydrogen bond 

formed,binding energy,interacting residues are shown in table no.1 and the result of interaction are shown in 

figure no 3 

 

Fig no 3 binding interaction 

 

 

  Table1 : No of hydrogen bonds,binding residues,binding energy of the docking process: 

 

 

Protein 

 

 

Crystal 

structure of 

SH2 domain 

of Grb10 

Ligand 

 

 

Cyclobutaneoctol 

No of 

hydrogen 

bonds 

 

3 hydrogen 

bonds 

 

Bond 

length 

 

 

 

Interacting 

residues 

 

 

 

Arg 447 

Lle 448 

Lle 532 

Gn 451 

Gln452 

 

Binding 

energy 

(Kcal/mol) 

 

 

 

-3.71 
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fig no 4 docking interaction  

 

CONCLUSION: 

In this study we performed with insulin receptors like Crystal structure of SH2 domain of Grb10 docked 

with cyclobutaneoctol as a ligand using the AUTODOCK TOOLS 1.5.7. Finally the docking score of 

cyclobutaneoctol found as -3.71Kcal/ mol. It shows evidently cyclobutaneoctol having strong affinity. With 

this result we looking forward to move on further investigations for a new drug development. 
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