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ABSTRACT:As environmental issues turn out to be greater severe and efficient trash management will become vital, the 

“Automated Waste Management System Utilizing Arduino Nano” offers a complete solution. In this mission, a top field 

mechanism with a servo-controlled lid is included with state-of-the-art sensor technology including metallic, soil moisture, and 

infrared sensors. In order to operate, the machine has to first detect waste objects transferring through the upper container. Only 

then can computerized techniques for garbage sorting and disposal be begun. The Arduino Nano microcontroller detects trash, 

and determines its type by reading sensor statistics, after which modifies the method as important. The rubbish is in the end 

transported to a segregation facility by means of servo cars that manual it onto a conveyor belt. The Arduino Nano provides 

correct manipulation through sensor feedback, permitting effective sorting into pre-designated boxes. Furthermore, the 

incorporation of an ESP32 module permits smooth interaction with a phone app, taking into account real-time rubbish-filling 

stage tracking. Users can remotely access important trash information by the usage of Bluetooth connectivity, which makes 

proactive waste control strategies feasible. This initiative offers a sustainable and flexible option for towns, companies, and 

groups that are committed to environmental stewardship. It marks a considerable development in the waste management era. 

Keywords :Arduino,Bluetooth,metallic,conveyor belt,soil moisture,infrared sensors. 
 

 

INTRODUCTION 

 

Rapid urbanization and population increase have brought about escalating concerns regarding waste management, necessitating 

the development of revolutionary answers to deal with these demanding situations. The &quot;Automatic Waste Management 

System Using Arduino Nano&quot; provides a singular approach to optimize waste segregation and monitoring tactics, 

leveraging advancements in microcontroller era and sensor integration. This project objectives to mitigate the detrimental 

environmental influences of inefficient waste management practices at the same time as selling sustainability and useful resource 

conservation. The proliferation of various types of waste, coupled with restrained assets and infrastructure for waste disposal, 

underscores the urgency for computerized systems capable of successfully sorting and coping with waste streams.Traditional 

waste management techniques frequently depend on guide sorting tactics, that are labour-extensive, errors-susceptible, and prone 

to inefficiencies. Moreover, inadequate tracking mechanisms contribute to troubles together with overflowing boxes, 

environmental pollutants, and compromised public health. In reaction to these demanding situations, the Automatic Waste 

Management System utilizes an array of sensors, such as a metallic sensor, soil moisture sensor, and IR sensor, to come across 

and classify waste items in real-time. The integration of Arduino Nano microcontroller era enables precisecontrol and 

coordination of the waste segregation technique, optimizing useful resource utilization and minimizing waste generation. Key 

features of the device consist of an upper container mechanism ready with a servo-managed cap for waste intake, a strolling belt 

system for waste transportation, and servo vehicles for guiding waste into exact boxes based totally on type. Furthermore, the 

incorporation of an ESP32 module facilitates Seamless verbal exchange with a cellular utility, empowering users to display 

dustbin filling reputation remotely and implement proactive waste management techniques. By automating waste segregation and 

tracking processes, the Automatic Waste Management System gives a scalable and sustainable answer for city environments, 

industries, and communities striving toward environmental sustainability. This task exemplifies the potential of era to deal with 

pressing environmental demanding situations and foster a cleaner, more healthy planet for destiny generations. 
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RESEARCH METHODOLOGY 

 

3.1 Proposed System: 

The Smart bin is divided into three compartments. Each Compartment has their own function, the first compartment 

Consists of an IR sensor and a metal detector and the second Compartment consists of another IR sensor and moisture 

Sensor for detecting dry and wet waste, the last compartment is subdivided into three bins for collection of the 

segregated Waste respectively. The whole system is controlled by Micro controller. Each and every component is 

interfaced to the microcontroller board. The necessary code for controlling the sensors and the motors is coded using 

embedded-C language, in which the inputs and the output ports can be defined easily. In this project we have used IDE 

compiler to compile the code and upload it to the board using an A-B wire. To provide details of every decision we 

have used a Liquid Crystal Display device to display the decisions made by the Arduino processor. 

 

3.2 Bluetooth: 

The role of Bluetooth in this Automatic Waste Management System is to enable seamless communication between the 

system and a mobile application. By utilizing Bluetooth connectivity, users can remotely access important information 

about the status of the dustbin, including waste levels. This allows for real-time monitoring and facilitates proactive 

waste management strategies, ensuring efficient utilization of resources and timely disposal of waste. 

 

3.3 Arduino Nano 

There is total 14 digital Pins and 8 Analog pins on your Nano board. The digital pins can be used to interface sensors by 

using  them as input pins or drive loads by using them as output pins. A simple function 

like pinMode() and digitalWrite() can be used to control their operation. The operating voltage is 0V and 5V for digital 

pins. The analog pins can measure analog voltage from 0V to 5V using any of the 8 Analog pins using a simple function 

like analogRead(). 

 

3.4 Resistive Soil Moisture sensor 

The sensor consists of two probes that are used to measure the volumetric content of water. The two probes allow the 

current to pass through the soil and then it gets the resistance value to measure the moisture value. When there is more 

water, the soil will conduct more electricity which means that there will be less resistance. Therefore, the moisture level 

will be higher. Dry soil conducts electricity poorly, so when there will be less water, then the soil will conduct less 

electricity which means that there will be more resistance. Therefore, the moisture level will be lower. 

  

3.5 LM2596 (DC TO DC Buck) 

This LM2596 Step Down Module is based on LM2596S-ADJ chip is one of the most cheap, easy to use, step down buck 

converter with adjustable output voltage, with high current output of upto 3A. This LM2596 step down module has a 

wide input voltage range from 4.5V to 35V. The LM2596 also has internal thermal shutdown, and current limit 

protection. It operates at switching frequency of 150 Khz, and is highly efficient with upto 73% Efficiency @ 12V 3A 

output.The output voltage of the module is adjustable according to the need by using the on board Potentiometer. As its a 

step down buck converter, the input voltage must higher than the required output voltage. The input voltage must be 

always 1.5V higher than the required output voltage.When using these modules remember that the output current will be 

a lot less than the input current, (remember - W = VA). For example, if you have a 10V output at 1A from a 5V input, the 

input current will be around 3.6A. The real-life maximum amount of power you can get out of these things is around 

10W. Output current is greater than 2.5A (or output power greater than 10W) to work long hours, please add heat sink. 

3.6 Metal Sensor 

An Metal sensor is a non-contact electronic proximity sensor used for the detection of metals. Sensing range of this sensor 

completely depends upon the metal being detected. Their working principle is based on a coil and an oscillator that 

generates an electromagnetic field in the surrounding of the sensing range. Presence of any metallic substance in the 

sensing range causes dampening of oscillation amplitude. 

3.7 MG90S-Metal Gear Micro Servo Motor 

MG90S is a micro servo motor with metal gear. This small and lightweight servo comes with high output power, thus ideal 

for RC Airplane, Quadcopter or Robotic Arms.There are lots of servo motors available in the market and each one has its 

own speciality and applications. Most of the hobby Servo motors operates from 4.8V to 6.5V, the higher the voltage 

higher the torque we can achieve, but most commonly they are operated at +5V.  Almost all hobby servo motors can rotate 

only from 0° to 180° due to their gear arrangement so make sure your project can live with the half circle. If no, you can 

prefer for a 0° to 360° motor or modify the motor to make a full circle.  

3.8 ESP32 – DevKitC 

The ESP32 is design for low power IoT applications in mind. It’s high processing power with in-built Wi-Fi / Bluetooth 

and  Deep Sleep Operating capabilities makes it ideal for most Portable IoT devices. Also now, since Arduino IDE has 

officially released board managers for ESP32, it has become very easy to program these devices 
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3.9 Arduino Installation 

            After learning about the main parts of the Arduino UNO board, we are ready to learn how to set up the Arduino IDE. Once 

we learn this, we will be ready to upload our program on the Arduino board. 

In this section, we will learn in easy steps, how to set up the Arduino IDE on our computer and prepare the board to 

receive the program via USB cable. 

Step 1 − First you must have your Arduino board (you can choose your favorite board) and a USB cable. In case you use   

Arduino UNO, Arduino Duemilanove, Nano, Arduino Mega 2560, or Diecimila, you will need a standard USB cable (A 

plug to B plug), the kind you would connect to a USB printer as shown in the following image. 

 

 

In case you use Arduino Nano, you will need an A to Mini-B cable instead as shown in the following image. 

 

 

 

 

Step 2 − Download Arduino IDE Software. 
You can get different versions of Arduino IDE from the Download page on the Arduino Official website. You must select 

your software, which is compatible with your operating system (Windows, IOS, or Linux). After your file download is 

complete, unzip the file. 

 

Step 3 − Power up your board. 

 

The Arduino Uno, Mega, Duemilanove and Arduino Nano automatically draw power from either, the USB connection 

to the computer or an external power supply. If you are using an Arduino Diecimila, you have to make sure that the 

board is configured to draw power from the USB connection. The power source is selected with a jumper, a small piece 

of plastic that fits onto two of the three pins between the USB and power jacks. Check that it is on the two pins closest 

to the USB port.Connect the Arduino board to your computer using the USB cable. The green power LED (labeled 

PWR) should glow. 

 

Step 4 − Launch Arduino IDE. 

After your Arduino IDE software is downloaded, you need to unzip the folder. Inside the folder, you can find the 

application icon with an infinity label (application.exe). Double-click the icon to start the IDE. 

http://www.ijrti.org/
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Step 5 − Open your first project. 

          Once the software starts, you have two options  

  Create a new project.  

Open an existing project example.  

To create a new project, select File → New.  
 

To open an existing project example, select File → Example → Basics → Blink 

Here, we are selecting just one of the examples with the name Blink. It turns the LED on and off with some time delay. 

You can select any other example from the list. 

Step 6 − Select your Arduino board. 

To avoid any error while uploading your program to the board, you must select the correct Arduino board name, which 

matches  with the board connected to your computer. 

Go to Tools → Board and select your board. 

 

Here, we have selected Arduino Uno board according to our tutorial, but you must select the name matching the board 

that  you are using. 

Step 7 − Select your serial port. 

 

Select the serial device of the Arduino board. Go to Tools → Serial Port menu. This is likely to be COM3 or higher 

(COM1   and COM2 are usually reserved for hardware serial ports). To find out, you can disconnect your Arduino board 

and re-open the menu, the entry that disappears should be of the Arduino board. Reconnect the board and select that serial 

port. 

http://www.ijrti.org/
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Step 8 − Upload the program to your board. 

Before explaining how we can upload our program to the board, we must demonstrate the function of each symbol 

appearing in  the Arduino IDE toolbar. 

 

A − Used to check if there is any compilation error. 

B − Used to upload a program to the Arduino board. 

C − Shortcut used to create a new sketch. 

D − Used to directly open one of the example sketch. 

E − Used to save your sketch. 

F − Serial monitor used to receive serial data from the board and send the serial data to the board. 

Now, simply click the "Upload" button in the environment. Wait a few seconds; you will see the RX and TX LEDs on   

the  board, flashing. If the upload is successful, the message "Done uploading" will appear in the status bar. 

3.10 Working  

 

The automatic waste management system operates seamlessly through a combination of sensors, actuators, and 

microcontroller  technology. At its core, the system employs a series of sensors strategically positioned within the upper 

container to detect the presence of waste as it passes through. These sensors include an infrared (IR) sensor for waste 

detection, a metal sensor for identifying metallic objects, and a soil moisture sensor for discerning organic waste based on its 

moisture content. Upon waste detection, the system springs into action, initiating a carefully orchestrated process of 

segregation and disposal. The upper container, equipped with a servo-controlled cap, opens to allow the waste to enter. As 

the waste descends, it traverses through the array of sensors, which collectively determine its composition and type.  

The data collected from these sensors is relayed to the Arduino Nano microcontroller, which serves as the brain of the 

system. The Arduino Nano processes the sensor data in real-time, employing programmed algorithms to analyze and classify 

the waste. Based on the sensor readings, the microcontroller precisely controls servo motors positioned at strategic points 

along the waste disposal route. These servo motors actuate gates or chutes, directing the waste into designated containers 

tailored to accommodate different waste types, such as plastic, paper, or glass. This automated segregation process ensures 

that each type of waste is efficiently sorted for proper disposal or recycling. Simultaneously, a running belt system 

positioned below the upper container facilitates the seamless transportation of waste to the segregation area. Once the waste 

has been appropriately sorted, it is deposited into the respective containers, ready for disposal or further processing. 

Throughout this process, the Arduino Nano continuously monitors the system's operation, adjusting servo motor movements 

and waste disposal mechanisms as needed to maintain efficiency and accuracy.  

In addition to its robust waste segregation capabilities, the automatic waste management system incorporates advanced 

communication technology for real-time monitoring and management. An ESP32 module integrated into the system collects 

data on dustbin filling status and wirelessly transmits this information via Bluetooth to a dedicated mobile application. This 

allows users to remotely monitor waste levels, receive notifications when bins are nearing capacity, and implement proactive 

waste management strategies. With its seamless integration of sensor technology, servo mechanisms, and wireless 

communication, the automatic waste management system represents a significant advancement in waste management 

http://www.ijrti.org/
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technology. By automating the process of waste segregation and providing real-time monitoring capabilities, the system 

offers a sustainable and efficient solution for optimizing waste disposal practices in urban environments, industries, and 

communities. 

 

 

 

 

3.11 Advantages & Disadvantages 

 

Advantages: 

- Increased efficiency through automation of waste management processes. 

- Enhanced accuracy in waste detection and segregation. 

- Optimal resource utilization and promotion of recycling efforts. 

- Real-time monitoring of dustbin filling status for proactive waste management. 

- Potential long-term cost savings by reducing labor requirements. 

- Environmental benefits including pollution mitigation and reduced carbon footprint. 

Disadvantages 

- Significant initial investment required for hardware and development. 

- Regular maintenance necessary to ensure optimal performance. 

- Technical complexity in design and implementation. 

- Susceptibility to technical failures, software glitches, and compatibility issues. 

- Limited scalability in larger-scale waste management facilities or urban areas. 

- Energy consumption associated with operation of electronic components. 

 

3.12  Applications 

 

- Efficient waste management in urban environments to reduce littering and improve cleanliness. 

- Streamlining waste disposal processes in commercial buildings like offices and shopping malls. 

- Effective management of industrial waste in factories and manufacturing plants. 

- Promoting recycling efforts and sustainable waste management practices in educational institutions. 

- Providing convenient waste disposal options for residents in residential communities. 

- Managing waste generated at public events, festivals, and concerts to maintain cleanliness. 

- Enhancing sanitation and cleanliness at tourist destinations for a better visitor experience. 

- Automating waste management in remote areas and off-grid communities to promote environmental sustainability.  

 

RESULTS & DISCUSSIONS 

 

The implementation of the automatic waste management system is anticipated to yield several significant outcomes. Firstly, the 

system is expected to enhance waste segregation processes, leading to increased recycling rates and reduced contamination of 

recyclable materials. This improvement in waste sorting efficiency is likely to result in cost savings and resource optimization 

over time. Moreover, by promoting recycling and proper waste disposal practices, the system aims to contribute to a reduction in 

environmental pollution and the mitigation of the carbon footprint associated with waste management activities. Additionally, the 

incorporation of real-time monitoring capabilities will enable proactive waste management strategies, allowing for timely 

interventions to address issues such as overflowing bins or waste buildup. Furthermore, community engagement and awareness 

about waste management and environmental sustainability are expected to increase as a result of the system's implementation, 

fostering a more environmentally conscious population. Overall, the implementation of the automatic waste management system 

is poised to bring about substantial improvements in waste management practices, resulting in cleaner, healthier, and more 

sustainable environments. 
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